Module 11: FEA for Design of the Advanced Ducted Propeller (ADP)

Table of Contents

<table>
<thead>
<tr>
<th>Section</th>
<th>Page Number</th>
</tr>
</thead>
<tbody>
<tr>
<td>Problem Description</td>
<td>2</td>
</tr>
<tr>
<td>Theory</td>
<td>3</td>
</tr>
<tr>
<td>Geometries</td>
<td>6</td>
</tr>
<tr>
<td>Workbench Layout</td>
<td>7</td>
</tr>
<tr>
<td>APDL: Static Structural Analysis</td>
<td>11</td>
</tr>
<tr>
<td>Workbench: Free Vibration</td>
<td>24</td>
</tr>
<tr>
<td>Workbench: Pre-Stressed Vibration</td>
<td>28</td>
</tr>
<tr>
<td>Results</td>
<td>30</td>
</tr>
<tr>
<td>Validation</td>
<td>33</td>
</tr>
</tbody>
</table>
Problem Description

Nomenclature:

\[ a = 4.686 \text{ in} \quad \text{Hub Radius} \]
\[ E_T = 1.65E7 \text{ psi} \quad \text{Young's Modulus of Titanium at Room Temperature} \]
\[ E_S = 29E6 \text{ psi} \quad \text{Young's Modulus of Steel at Room Temperature} \]
\[ L = 6.314 \text{ in} \quad \text{Length of blade} \]
\[ \nu_t = 0.342 \quad \text{Poisson's Ratio of Titanium} \]
\[ \nu_s = 0.300 \quad \text{Poisson's Ratio of Steel} \]
\[ \rho = 0.16 \frac{lb}{in^3} \quad \text{Density of Titanium at Room Temperature} \]
\[ \omega = 8400 \text{ rpm} = 879.65 \text{ rad/s} \quad \text{Angular Speed} \]
\[ \theta = 74.6965 \quad \text{Stagger Angle} \]

In this module, we will analyze the rotating stresses and deflections of a fan blade and use this data to find the pre-stressed frequencies of the blade. We will also calculate the natural frequencies of the blade to make sure that the blade doesn’t operate at a natural frequency. This analysis will use tools from both ANSYS Workbench and ANSYS Mechanical APDL and will use your previous knowledge from modules 1, 6, and 11. If you have not completed the requisite tutorials, please go back and do so to gain further insight from this tutorial.

The fan blade we will be studying is the Advanced Ducted Propeller (ADP). This fan was designed by Pratt and Whitney and NASA as a low noise propeller with adequate low cycle fatigue life and an acceptable operating range without resonant stress or flutter. One of the main goals of this tutorial is to prove that the blade does not operate at a resonant frequency while under load.
Theory
The main design goals of the APDL are as follows:

- Minimize Pull
- Account for tip clearance
- Account for free and pre-stressed resonant stresses

While in real life an aerodynamic load is placed on the blade as well, we have neglected this load for validation purposes. We will see that the rotating stresses of the blade match closely with the physics presented in Module 6, the Rotation Loading of a Cantilever Beam.

Minimize Pull and Tip Clearance

In module 6, we reviewed the theory behind the stresses and deflections in a rotating cantilevered beam. The resulting equations were as follows:

\[ \sigma(x) = \frac{\rho \omega^2}{2} ((L + a)^2 - x^2) \times \frac{1}{386.4} \]  \hspace{1cm} (11.1)

\[ U(x) = \frac{\rho \omega^2}{2E} \left( (L + a)^2 (x - a) + \frac{a^2-x^3}{3} \right) \times \frac{1}{386.4} \]  \hspace{1cm} (11.2)

The blade in this problem has a mass roughly 1.5 times greater than the beam used in module 6, however the center of mass of the blade is at roughly a quarter the span of the blade. Since the blade does not have a constant cross sectional area, we cannot use the above equations to exactly quantify the radial stress and deflection of the blade. The effect of the added mass, however, should be balanced by the CG located closer to the center of rotation. Thus, we would expect stresses and deflections to be within the same order of magnitude of the values calculated in module 6.
Free and Pre-Stressed Resonant Frequencies

\[ E I \frac{d^4 y}{d x^4} + \rho A \frac{d^2 y}{d t^2} = 0 \] \hspace{1cm} (11.3)

\[ \omega_n = \frac{f_n}{2\pi} = \frac{\beta_n}{2\pi} \sqrt{\frac{E I}{\rho A}} \] \hspace{1cm} (11.4)

In module 10, we analyzed the free vibration mode shapes and natural frequencies of a 1D cantilevered beam using Euler-Bernoulli Beam Theory. As one can see from equation 11.3 and 11.4, the natural frequencies of the blade are a function of the length of the beam, Young’s Modulus, moment of inertia, density, and cross sectional area. Rerunning module 10 with the beam properties of module 6, the tutorial creators have gathered data about the natural frequencies of the above cantilever beam. The blade is roughly equivalent in length and was given the same material properties as the ADP (\( \rho, E \)). We do not expect, however, the beam to have the same radius of gyration (\( \zeta \)) as the fan blade.

\[ \zeta = \sqrt{\frac{I}{A}} \] \hspace{1cm} (11.5)

The blade does not have a uniform cross section so \( \zeta \) is a function of the radial direction. Thus, we would not expect that the natural frequencies of the blade to correlate to the natural frequencies of the beam, but these frequencies should scale in a similar fashion.

Another consideration is the stiffening of the blade due to the stresses covered in equation 11.1. For a single degree of freedom system:

\[ \omega_n \sim \sqrt{\frac{k}{m}} \] \hspace{1cm} (11.6)

Where \( k \) represents the stiffness terms and \( m \) represents the mass terms. Since the stress stiffness matrix increases with tension applied to the blade, we would expect the natural frequencies to rise due to inertial stress.
Above is the result of the same cantilever beam rotating at 8400 RPM, the operating angular speed of the fan. As one can see, the beam under load exhibits higher natural frequencies than the beams under no load. If this beam were the production part, the stress stiffening effect would be a great advantage since it prevents the beam from being operated at one of its no load resonant frequencies. Since we do not want the ADP to operate at a resonant frequency causing large stresses, we will monitor this effect as a major design consideration.

In addition to these natural frequencies, there are torsional natural frequencies as well which must be accounted for. As shown on page 2, since the blades are staggered from the axis of rotation, the blades desire to twist into a position such that their principle axes are either in line or perpendicular to the axis of rotation. The 1D module did not take this stagger into consideration. This reciprocating torsion makes the torsional natural frequencies important from a resonant stress standpoint. These torsional modes should be roughly the same order of magnitude as the resonant frequencies.
**Geometries**

**ADP_Fan solid block fillet 2.SLDPRT**

This Geometry will be used to analyze the rotational stresses and deflections of the blade. In this Geometry, a fictitious base of steel has been added to simulate the hub. This base has no mass as to not alter the stresses and deflections in the blade. The blade is attached to the base with a fillet. The reason for including this geometry is to mitigate the fictitious stress concentrations that appear at the blade root when modeling the blade by itself. This geometry will be meshed in ANSYS Workbench and imported into ANSYS Mechanical APDL.

**ADP_Fan solid.SLDPRT**

This Geometry will be used to perform our modal analysis. The addition of the base drastically affects the natural frequencies of the beam ($\sim L^2$) while the stress concentrations at the corners do little to alter the pre-stressed modes. This analysis will be done in Workbench.
**Workbench Layout**

We will first organize the workbench environment to suit our analysis.

**Opening Workbench**

1. On your Windows 7 Desktop click the **Start** button.
2. Under **Search Programs and Files** type “ANSYS”
3. Click on **ANSYS Workbench** to start workbench. This step may take time.

**Analysis Setup**

1. Go to **Toolbox -> Component Systems -> Mesh** and drag and drop into **Project Schematic**
2. Under Module A, click the **Static Structural(ANSYS)** title and replace with **Fan Stresses and Deflections**
3. Go to Toolbox -> Component Systems -> Mechanical APDL and drag and drop into Project Schematic next to Module A

4. Go to Project Schematic -> Module A -> Mesh and drag a connection wire to Project Schematic -> Module B -> Analysis

5. Under Module B change the title to *Fan Stresses and Deflections*

6. Go to Toolbox -> Analysis Systems -> Modal (ANSYS) and drag and drop into Project Schematic -> Create Standalone System

7. Under Module C change the title to *Free Vibration*
8. Go to Toolbox -> Analysis Systems -> Static Structural (ANSYS) and drag and drop into Project Schematic -> Create Standalone System

9. Under Module D change the title to Pre-Stressed Vibrations

10. Go to Toolbox -> Analysis Systems -> Modal (ANSYS) and drag and drop into Project Schematic -> Module D -> Solution
11. Under Module E change the title to *Pre-Stressed Vibrations*

12. Go to **Project Schematic** - Module C - > **Engineering Data** and drag a connection wire to **Project Schematic** - Module D - > **Engineering Data**

13. Repeat step 12 for **Geometry**
14. Go to **Project Schematic -> Module A -> Geometry** and right click. Go to **Import Geometry -> Browse…** and select **ADP_Fan solid block fillet 2.SLDPRT** from the directory you saved it in earlier.

15. Go to **Project Schematic -> Module C -> Geometry** and right click. Go to **Import Geometry -> Browse…** and select **ADP_Fan solid.SLDPRT** from the directory you saved it in earlier.

**APDL: Static Structural Analysis**

**Geometry**

1. Go to **Project Schematic -> Module A -> Geometry** and double click.
2. Select **Meter**
3. Press **OK**
4. Maximize the **Design Modeler**

One of the problems with **ANSYS Mechanical APDL** is that it automatically converts your domain into metric units. In order to overcome this problem, the geometries you imported were scaled to meters. For example, if a dimension in the drawing was 6 in, it was scaled to 6 m. This was done because our data was given in English units and we wanted our answers to be consistent with our validation plots. In order to maintain consistent modeling, later we will model properties as metric units in **Workbench**, but our answers will really be in English units.

5. Press **Generate**. The geometry might take a few minutes to load. Below is the resulting screen:
Mesh

1. Close out of Design Modeler
2. Go to Workbench -> Project Schematic -> Module A -> Mesh and double click
3. Maximize the Meshing Window
4. Go to Meshing Options -> Physics Preference -> Mechanical
5. Click OK

We will mesh the blade and base in ANSYS Workbench since the Automatic Meshing options are powerful and have the capacity to create hex dominant meshes with little effort and invested time. If we wanted the blade to be made entirely of 8 node elements, it is easiest to split the geometries in the CAD software of your choice due to the complexity of the geometry. For more information on Multi-Zone Mapped Meshing concepts, please read Module 8. It is possible to create a mesh entirely out of linear elements from the automatic mesher, but since we are using the student version of ANSYS, we would exceed the maximum node limit.

**WARNING:** The student edition of ANSYS has a 512,000 node limit. Thus unfortunately for this tutorial you will not be able to perform a mesh refinement study since further refinement would push the solver over the maximum node limit. The model will be accurate enough for validation so we will neglect this concern for the purpose of instruction.

6. Go to Outline -> Project -> Model (A3) -> Mesh
7. Go to Details of “Mesh” -> Advanced -> Element Midsize Nodes -> Dropped. This will create elements without midsize nodes.
8. Go to Details of “Mesh” -> Sizing -> Use Advanced Size Function -> On: Curvature
   This will add elements near the leading and trailing edges of the blade as well as the root near the fillet.
9. Go to Details of “Mesh” -> Sizing -> Relevance Center -> Fine
10. Click Update
11. Go to Details of “Mesh” -> Statistics notice our model uses 10325 nodes. Since the license accepts up to 512000, we should be ok.
12. Close the Meshing window
Analysis

1. In Workbench click Update Project and give the program a few minutes to update. Ignore any warnings about Modules C and D

Module B should have a green check mark next to analysis. That means we can export our mesh to ANSYS Mechanical APDL

2. Go to Project Schematic -> Module B -> Analysis and right click. Click Edit in Mechanical APDL…

3. When APDL opens, you will see that the nodes have been plotted. Go to Utility Menu -> Plot -> Elements

The resulting plot is shown:

Due to a bug with the mesh import, we will have to save and restart the APDL analysis. This will stop the geometry from updating slowly and will allow the user to view node and element numbers.

Saving Mesh

It would be convenient to save the mesh so that it does not have to be made again from scratch.

1. Go to File -> Save As …
2. Under Save Database to pick a name for the Mesh. For this tutorial, we will name the file ‘Fan Stresses and Deflections’
3. Under Directories: pick the Folder you would like to save the .db file to.
4. Click OK
Rebooting APDL

1. Close out of APDL
2. Select Save Geom + Loads
3. Click OK

4. Restart ANSYS Mechanical APDL
5. Go to Utility Menu and click . Search for Fan Stresses and Deflections.db and open.
6. Go to Utility Menu -> PlotCtrls -> Numbering… and check NODE
7. Press OK

The plot should look as follows:

Since the node numbers appear, we have resolved the bug and the Geometry window should update faster.

8. Go to Utility Menu -> PlotCtrls -> Numbering… and check off Node
9. Click OK
Element Type and Material Properties

1. Go to Main Menu -> Preprocessor -> Element Type -> Add/Edit/Delete

The current mesh is made with MESH200, a linear element without midsize nodes and 0 DOF. Basically MESH200 acts as a placeholder to be replaced by another native APDL element of similar type. For this tutorial, we will use SOLID 185 as we are accustomed to.

2. Click Add
3. Go to Library of Element Types -> Solid -> 8node 185
4. Click OK
5. Click Close

7. Under EX enter 29E6
8. Under PRXY enter .3
9. Click OK
10. Go to Define Material Model Behavior -> Material -> New Model…
11. Click OK
12. Go to Material Model Number 2 -> Structural -> Linear -> Elastic -> Isotropic
13. Under EX enter 1.65E7
14. Under PRXY enter .423
15. Click OK
16. Go to Material Model Number 2 -> Structural -> Density
17. Under DENS enter 0.16/386.4
18. Press OK
19. Go out of Define Material Model Behavior
20. Go to Utility Menu -> SAVE_DB

Now we will replace the current mesh and materials with the ones we have specified. The base will be steel (material model 1) and the blade will be titanium (material model 2).

1. Go to Main Menu -> Preprocessor -> Modeling -> Move/Modifyv -> Elements -> Modify Attributes
2. Click Pick All
3. Under STLOC select Elem type TYPE
4. Under I1 select 2. This chooses SOLID185
5. Click OK
6. Using the \textbf{Dynamic Model Mode} orient the blade as shown below:

7. Go to Main Menu -> Preprocessor -> Modeling -> Move/Modify -> Elements -> Modify Attributes
8. Click Box
9. Draw a box from just to the right of the left face of the base to the end of the base:

10. Click OK
11. Under STLOC select Material MAT
12. Under I1 enter 1
13. Click OK

14. Using the \textbf{Dynamic Model Mode} pan over to the screen position as shown below:

15. Go to Main Menu -> Preprocessor -> Modeling -> Move/Modify -> Elements -> Modify Attributes
16. Click Box
17. Draw a box around the blade to just before the block starts.

18. Click OK.
19. Under STLOC select Material MAT
20. Under I1 enter 2
21. Click OK
22. Zoom in closer to the root and repeat steps 15–21 for the elements at the root.

We just created a base of steel and a blade of titanium. Since the base was modeled without mass, no additional stresses will be added to the blade while rotating, limiting our analysis to the blade and assuming the hub to be a rigid body.

23. Let’s check the elements and material properties to make sure we didn’t miss any. Go to Utility Menu -> List -> Elements -> Attributes Only

Check to see that in the MAT and TYP columns that TYP 2 is always selected (element type 2, SOLID185) And MAT equals either 1 or 2 (steel, titanium)
Inertia Loads

The origin in our model is not located at the center of rotation. The center of rotation is at the bottom of the base. Thus, we must find the coordinates of the nodes at the base.

1. Go to Utility Menu -> List -> Nodes ->
2. Under Output listing will contain select Coordinates only
3. Under Sort first by select Z Coordinate
4. Click OK

Clearly the foot of the base is located at Z= -3.3264.

5. Close out of the NLIST window.
6. Go to Main Menu -> Preprocessor -> Loads -> Define Loads -> Apply -> Structural -> Inertia -> Coriolis Effects and fill the table as shown:

```
[CGLOC] Origin of Acceleration Coordinate System
X,Y,Z global Cartesian coords
0       0       -3.3264

[CGOMGA] Angular Velocity about Acceleration Coordinate System
X,Y,Z components of ang velocity
232.1678 848.4368 0
d
[DCGOMG] Angular Acceleration about Acceleration Coordinate System
X,Y,Z components of ang accel
0       0       0
```

7. Click OK

**DOF Constraints**

1. Go to Utility Menu -> Plot -> Nodes
2. Using the Dynamic Model Mode zoom in on the nodes at the foot of the base.
3. Go to Main Menu -> Preprocessor -> Loads -> Define Loads -> Apply -> Displacement -> On Nodes
4. Click Box and box the nodes at the foot of the base:

5. Click OK
6. Under **Lab2 DOFs to be constrained** select **All DOF**
7. Under **Value**, enter **0**
8. Click **OK**

9. Using the [Dynamic Model Mode](https://www.ansys.com/documentation) pan over to the top of the base.
10. Go to **Main Menu > Preprocessor > Loads > Define Loads > Apply > Displacement > On Nodes**
11. Click the nodes at the corners of the top of the base
12. Click **OK**
13. Repeat steps 6-8. The displacements should look as shown:

![Displacements](image)

**Solution**

1. Go to **Main Menu > Solution > Solve > Current LS (solve)**. LS stands for Load Step. This step may take some time depending on mesh size and the speed of your computer (generally a minute or less). Ignore all warnings. They pertain mostly to element shape checking concerns.
1. Go to Main Menu -> General Postprocessor -> Plot Results -> Contour Plot -> Nodal Solution -> Stress -> Z-Component of stress
2. Click OK
3. Go to Utility Menu -> PlotCtrls -> Style -> Contours -> Uniform Contours…
4. Under Contour intervals select User Specified
5. Under VMIN enter 0
6. Under VMAX enter 18500
7. Click OK

The resulting plot should look as follows:

Neglecting the stress concentrations in the corners, the maximum stress appears to be ~18.5 ksi
Tip Clearance

1. Go to Main Menu -> General Postprocessor -> Plot Results -> Contour Plot -> Nodal Solution -> DOF Solution -> Z-Component of Displacement
2. Click OK
3. Go to Utility Menu -> PlotCtrls -> Style -> Contours -> Uniform Contours...
4. Under Contour intervals select Auto Calculated
5. Click OK

The resulting plot is shown below:

It appears as though the tip of the blade deflects more than its center due to twisting. The max displacement is 0.019 in. The max centerline displacement is about 0.005 in.
Workbench: Free Vibration

Engineering Data

1. Go to Workbench -> Project Schematic -> Module C -> Engineering Data and double click
2. Under Outline of Schematic cell 4A enter Ti
3. Go to Toolbox -> Density
4. Under Properties of Outline Row 4: Ti -> Density enter 0.00041408
5. Go to Toolbox -> Linear Elastic -> Isotropic Elasticity
6. Under Properties of Outline Row 4: Ti -> Young’s Modulus enter 1.65E7
7. Under Properties of Outline Row 4: Ti -> Poisson’s Ratio enter 0.342
8. Click [Return to Project] followed by [Update Project]
Model

1. Go to Workbench -> Project Schematic -> Module C -> Model and double click.
2. Go to Outline -> Project -> Model (C4) -> Mesh
3. Go to Details of “Mesh” -> Sizing -> Relevance Center -> Medium
4. Click Update

Wait a few minutes for the mesh to update. The mesh should look like:

5. Go to Outline -> Geometry -> ADP_Fan solid
6. Go to Details of “ADP_Fan solid” -> Material -> Assignment and switch to Ti.
7. Using the middle mouse, rotate the blade so that the root is visible.
8. Using the Face tool, select the root of the blade
9. Go to Outline -> Project -> Modal (C5) and right click. Go to Insert -> Fixed Support

10. Go to Outline -> Project -> Modal (C5) -> Analysis Settings
11. Under Max Modes to Find select 20
12. Click Solve

Wait a few minutes for ANSYS to find the modes.
13. Go to Outline -> Solution (C6)
14. Right click on Graph and pick Select All
15. Right click on Graph and pick Create Mode Shape Results this will generate contour plots of the mode shapes
16. Click Solve

17. Go to Outline -> Solution (C6) -> Total Deformation. Under Graph, if you press you can animate the mode shape.

18. Close C: Free Vibrations – Mechanical

Boxed in red are the results for the fundamental frequencies of the blade. This is a mixed list of torsional and translational modes so it is best to animate the modes to determine which type they are.

18. Close C: Free Vibrations – Mechanical
**Workbench: Pre-Stressed Vibration**

1. Go to **Workbench -> Project Schematic -> Module D -> Model** and double click
2. See Page 25 for information on meshing the blade and changing material properties.
3. Using the middle mouse, rotate the blade so that the root is visible.
4. Using the **Face** tool, select the root of the blade
5. Go to **Outline -> Project -> Static Structural (D5)** and right click. Go to **Insert -> Fixed Support**
6. Go to **Outline -> Project -> Static Structural (D5)** and right click. Go to **Insert -> Rotational Velocity**
7. From inspecting the CAD file, we can determine that the center of rotation is at **0,0,-7.5536**. Enter the coordinates and rotational velocity components as shown:
8. Go to Outline -> Project -> Modal (E5) -> Analysis Settings
9. Under Max Modes to Find select 20
10. Click Solve

11. Go to Outline -> Solution (E6)
12. Right click on Graph and pick Select All
13. Right click on Graph and pick Create Mode Shape Results this will generate contour plots of the mode shapes
14. Click Solve

15. Go to Outline -> Solution (E6) -> Total Deformation. Under Graph, if you press you can animate the mode shape.

Boxed in red are the results for the pre-stressed frequencies of the blade. This is a mixed list of torsional and translational modes so it is best to animate the modes to determine which type they are.

16. Close Multiple Systems - Mechanical
Results

Pull

The maximum pull on the blade is ~18.5 ksi. This value is comparable to the ~16 ksi of the rotating cantilever beam shown in the validation section. Due to Poisson’s Effect, we get large stress concentration at the corners of the blade and a lower stress at the root center. The stress amplification at the corners is roughly 4:1 the max pull on the blade. The blade exhibits a radial decrease in stress as predicted by the theory. Since the blade does not have constant thickness, the contours exhibit lower stress behavior at the leading and trailing edges than at the location of max thickness since less mass is being pulled at these locations.
Tip Clearance

The required tip clearance is ~ 0.020 in in order to increase the deflection of the blade. The deflection down the middle of the blade is roughly 0.005 in. The rotating beam had a max deflection of 0.003443 in, but also contained less mass. Part of the additional deflection can be attributed to the untwisting of the blade due to the rotating stress.
Vibration Analysis

As one can see from the results, for the first two Translational and Torsional frequencies increased after pre-stress. The third mode onward did not exhibit this behavior. This can be attributed to the coarse mesh. From Nyquist Frequency concepts discussed in earlier tutorials, we know that we need at least 2 nodes located within half the wavelength of the frequency desired to be calculated. One observation from this data is that the blade does not enter either the first translational or torsional vibrational modes while ramping up to cruise rotational speed. This was a necessary design condition for the blade, and helps validate our results.
Validation

To validate the stress along the Z-axis, we tested different physical examples: Rotating beam with 1D and 2D elements and a 2D Staggered Beam. The first two runs aligned perfectly with equation 11.1 and 11.2. The Staggered Beam aligned with equation 11.2, but had variations from equation 11.1 due to stress concentrations in the base corners. This deviation can be attributed to the blade twisting to align with the principle axes while rotating. Since the blade has more mass, it is expected that the stress would be higher as shown in the results section and has similar stress concentrations as the 2D beam.
As shown above, the beam stiffens when stressed. This can be attributed to the updated stiffness matrix in the static structural solution before the forced vibration is calculated. Similar behavior was shown on the Fan Blade, as previously discussed.